Подключение репозитория HP с системными утилитами

Management Component Pack

hp-health HPE System Health Application and Command line Utilities
hponcfg HPE RILOE II/iLO online configuration utility
hp-ams HPE Agentless Management Service
hp-snmp-agents Insight Management SNMP Agents for HPE ProLiant Systems
hpsmh HPE System Management Homepage
hp-smh-templates HPE System Management Homepage Templates
hpssacli HPE Command Line Smart Storage Administration Utility
hpssaducli HPE Command Line Smart Storage Administration Diagnostics
hpssa HPE Array Smart Storage Administration Service

Создаём файл с описанием репозитория /etc/yum.repos.d/mcp.repo:
[mcp]
name=Management Component Pack
baseurl=http://downloads.linux.hpe.com/repo/mcp/dist/dist_ver/arch/project_ver
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/GPG-KEY-mcp

Где:
dist          centos, feodra, opensuse, oracle, asianux
   dist_ver      Browse repo to identify supported distribution versions
   arch          i386, x86_64,  amd64(debian/ubuntu)
   project_ver   current, 10.50, 10.40, 10.20, 10.00, 9.30, 9.25, 9.10 (Browse repo to identify supported project versions)

В моём случае (CentOS 6.8) получился вот такой файл:
[mcp]
name=Management Component Pack
baseurl=http://downloads.linux.hpe.com/repo/mcp/centos/6.8/x86_64/current
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/GPG-KEY-mcp


Посмотреть список пакетов из этого репозитория:
# yum --disablerepo="*" --enablerepo="mcp" list available


Установить пакет:
# yum install packagename
Например:
# yum install hp-health

Cisco: DHCP для выдачи DNS-сервера IPv6-клиентам

Есть PPPoE-клиенты, которые получают IPv6-адреса через SLAAC, префикс сети передаётся Radius-сом, также из Radius-а передаётся маршрут на дополнительную подсеть. Но вот адрес DNS-сервера выдать клиенту можно пока только через DHCP. Команда «ipv6 nd ra-dns-server» не работает, avpair «ipv6-dns-servers-addr» тоже.

Впрочем настройка DHCP-сервера для этих задач совсем несложная, заодно передадим и домен по-умолчанию:
!
ipv6 dhcp server IPV6_DHCP
dns-server 2001:db8:1::1
domain-name elcat.kg
!
interface Virtual-Template1
ipv6 nd other-config-flag
ipv6 dhcp server IPV6_DHCP
!

Опция «ipv6 nd other-config-flag» указывает, кто хостам надо использовать DHCP для других настроек, кроме получения адреса:
Hosts should use DHCP for non-address config

CentOS: данные по сетевой карте

# ip -s -s link show eno1
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
    link/ether e0:07:1b:f8:21:64 brd ff:ff:ff:ff:ff:ff
    RX: bytes  packets  errors  dropped overrun mcast
    1762937170427 11152407427 0       9422    0       3579554
    RX errors: length   crc     frame   fifo    missed
               0        0       0       0       0
    TX: bytes  packets  errors  dropped carrier collsns
    24857233171258 18559176680 0       0       0       0
    TX errors: aborted  fifo   window heartbeat
               0        0       0       0


# ethtool -g eno1
Ring parameters for eno1:
Pre-set maximums:
RX:             2047
RX Mini:        0
RX Jumbo:       0
TX:             511
Current hardware settings:
RX:             200
RX Mini:        0
RX Jumbo:       0
TX:             511


Поменять текущий параметр (до перезагрузки):
# ethtool -G eno1 rx 1024

Прописать параметр насовсем можно в /etc/sysconfig/network-scripts/ifcfg-eno1:
ETHTOOL_OPTS="-G eno1 rx 1024"

Cisco: IPv6 OSPF

Как настраивать IPv6 на циске писать не буду, да и вообще обойдусь минимумов слов )

Роутер R1
!
interface Vlan111
description R1
ipv6 address FE80::12 link-local
ipv6 address 2001:0db8:1::219/64
ipv6 ospf mtu-ignore
ipv6 ospf 1 area 0
!
router ospfv3 1
router-id 1.1.1.219
passive-interface default
no passive-interface Vlan111
!
address-family ipv6 unicast
area 0 range 2001:0db8::/32
default-information originate
redistribute connected
redistribute static
exit-address-family
!

Роутер R2
!
interface Vlan111
description R2
ipv6 address 2001:0db8:1::247/64
ipv6 ospf 1 area 0
ipv6 ospf mtu-ignore
!
router ospfv3 1
router-id 1.1.1.247
!
address-family ipv6 unicast
passive-interface default
no passive-interface Vlan222
redistribute connected
redistribute static
area 0 range 2001:0db8::/32
exit-address-family
!


Без команды «ipv6 ospf mtu-ignore», заданной на интерфейсах соседи постоянно падают с жалобой «Neighbor Down: Too many retransmissions» и никакие маршруты не передаются.

Команда «default-information originate» на роутере R1 даёт указание роутеру отправлять соседям ещё и default-route.

Несколько команд, чтобы посмотреть интересную информацию:
sh ipv6 route ospf
sh ipv6 ospf database

SSL-cертификат для postfix

Коротенько )

/etc/postfix/main.cf:
smtpd_use_tls = yes
smtpd_tls_auth_only = no

smtpd_tls_key_file = /etc/postfix/tls/mymail.key
smtpd_tls_cert_file = /etc/postfix/tls/mymail.crt
smtpd_tls_CAfile = /etc/postfix/tls/CA_bundle.pem

Создаём новый приватный ключ:
openssl genrsa -des3 -out mymail.key 2048

Создаём запрос для получения сертификата:
openssl req -new -key mymail.key -out mymail.csr

Заказываем сертификат на сайте регистратора. Я пользуюсь услугами Dynadot.com.

Создаём ключ без пароля:
openssl rsa -in mymail.key -out mymail-nopwd.key

Копируем ключ и сертификат в нужную папку:
cp mymail-nopwd.key /etc/postfix/tls/
cp mymail.crt /etc/postfix/tls/

Создаём промежуточный сертификат: берём отсюда корневой сертификат и сертификат нужного цетра сертификации (в данном случае AlphaSSL) и копируем в один файл CA_bundle.pem:
-----BEGIN CERTIFICATE-----
Корневой сертификат
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
Промежуточный сертификат AlphaSSL
-----END CERTIFICATE-----


Ну и перезапускаем postfix.

Конечно, после обновления сертификата (если приватный ключ остался прежний) не нужно всё это делать заново, достаточно просто скопировать новый сертификат в файл mymail.crt. Ну и на всякий случай убедиться, что корневой и промежуточный сертификаты не изменились.

Копирование конфигурации Mikrotik-а на ФТП-сервер

Сначала экспортируем конфигурацию в файл на самом Mikrotik-е:
/export file=r1-config1701
Операция занимает несколько секунд.

Затем можно копировать его на ФТП-сервер:
/tool fetch address=10.0.1.3 user=ftp1 password=PWD123 mode=ftp src-path=r1-config1701.rsc dst-path="/tmp/r1-config1701.txt" upload=yes

rsc — расширение файла, которое Mikrotik добавляет сам, а я хочу, чтобы на ФТП-сервере получился файл с расширением txt.

Посмотреть список файлов на Mikrotik-е:
/file print

Для регулярного копирования можно прямо на Mikrotik-е написать скрипт и запускать его из шедулера. Этим я пока не занимался, т.к. конфигурация роутера меняется редко.

Девушка с холодным расчётом, но тёплым сердцем



Мне очень сильно повезло встретиться с пресс — секретарём Федерации футбола Кыргызской Республики Натальей Угрюмовой, когда я был волонтёром на матчах национальной сборной. Строгий классический костюм, который идеально ей подходит, кстати; организаторские способности, точный принцип работы, фотоаппарат для снимков игроков сборной, различные предметы технологий, которые знает даже детсадовский ребёнок, кроме меня – всё это у неё в руке. Я с широко раскрытыми глазами смотрел за её работой и понимал в такую девушку не влюбиться невозможно! В упорной борьбе между работой и собой — Наталья с успехом справлялась в каждом “тайме”. Хотя, девушка и футбол – две разные вещи, но в нашем мире найти себя и получать удовольствие от спорта №1, когда ты представительница слабого пола… – я просто не мог взять у неё интервью и не поинтересоваться: «что же для неё футбол?»


Читать дальше →

Как быть?..

Изгнать людскую партию,
Гулящую по нашей земле.
Забыть о человечности.
Забыть о чёртовой игре.

Кукловоды бумажными руками
Издают смех, смотря нам в лицо.
Мы не обращаем внимание –
Наши мысли совсем о другом.

Оглянувшись по нынешним сторонам,
Всё вокруг не белым – бело.
Решить вопрос по твоим пустякам –
Для других очень легко.

Сколько уже живём,
Мой читатель?
Всё равно по знакомой
Дорожке идём.
Где плохо и хорошо
До сих пор не разберём?..

В самом деле, надо сдвинуться
с места.
Хотя человек выйдет сухим.
Мы сами создаём своё тесто;
Только вот считать – ли
Процесс этот правильным?

Я не знаю ответа на вопрос.
Забавно: а ведь можно решить
Таким путём любой допрос.
Короче день, длиннее ночь –
Однако человечность
Только сумеет нам помочь.

***

Мне трудно жизнь даётся.
Перемены – сложный процесс.
Недавно старый знакомый написал письмо.
А я не могу открыть занавес.

— «Что произошло? Как живёшь?»
[Ничего не сохранилось в душе]
— «Столько лет мы не виделись?!
Какие новости у тебя. Расскажи?»
********************************************
Парень с седыми волосами
Открыл очередную дверь.
Каждый день своими слезами
Он видит новый день.
Сердце требует романтической любви.
Голова останавливает в начале же пути.
После, старается не перелистывать книги,
Которые четыре года создавали.

Друзья, слава богу, отличные.
Он дорожит ими всей душой.
Никогда не были беседы с ними сложные.
Отвлекает редко, когда наедине с судьбой.

Мама, Бабушка, Родные живы.
На воздухе проводят время
Больше, чем он.
Дай им всем огромные силы.

…Как-то с малых лет
Некий мальчик по имени Адилет
Не расставался с бумагой и пером.
Родители замечали их часто втроём.
Никто не читал – что произошло
С этой троицей потом?

Не даёт ему покоя загадочный человек.
Хочется узнать – что пережил подлец?
Пёс с ним! Оставил его в сторону.
Ему нужно сбрить сейчас свою бороду.
Оставить письмо, пожалуй, последнее.
Словечки оставить искреннее.
Посмотреть в окно, как уходит день.
Закрыть глаза и оставшуюся дверь.
********************************************
Мне трудно жизнь давалась.
Перемены – сложный процесс.
За мой период ничто не собралось.
Я не смогу открыть тебе занавес.


Мой ближайший рейс в тот день «Милан» - Бишкек – «Интер» [всё по-простому]



Чтобы не быть многословным и раскрыть главных героев ближайшей центральной игры Серии А 16/17 13 ого тура: собрать за один стол миролюбивых врагов – дельце вышло простым. И Жоомарт [миланиста], и Омурбек [интериста] с удовольствием согласились побеседовать в преддверии миланского дерби со мной, за что им отдельная большая благодарность. Хочу отметить сразу, за всё общение, которое происходило в уютном кафе – ни одна посуда не была разбита; никто из сидящих рядом за нашим столиком не пострадал, а официанты прекрасно сработали в такой ситуации. Мне лишь осталось попросить для интервью моих героев надеть законные их цвета, взять с собой сестру для проявления фотографии и мне включить диктофон.



Примечание. М – болельщик «Милана» Жоомарт, И – тифози «Интера» Омурбек.

1.Каково наблюдать за переходным состоянием своего клуба из рук итальянских владельцев китайцам?

И. Для меня важно, как и для любого болельщика, чтобы хозяином команды был – фанат. Я бы сказал не фанат, а настоящий фанатик. Страстно болеющий, переживающий за свою команду. Мы видели, что Эрик Тохир проявил себя, в большей степени, как бизнесмен; не хотелось бы ожидать от нынешних владельцев “нерадзурри”, в данный момент, а мы говорим о китайцах, проявление себя в этом же аспекте. Так или иначе, замечаем, что реалии сегодняшнего рынка – без достаточных инвестиции удержаться на плову будет сложно. Взглянув на современный футбол, несколько лет тому назад 100 млн. ценник за одного футболиста, казалось неописуемым. Сейчас итальянские клубы проводят сделки, где Игуаин и Погба, в общей сложности равны колоссальным цифрам. Хотя, на них никто и не ставил по всему миру. Поэтому, чтобы на рынке быть конкурентоспособным нужно иметь в виду, что в кармане достаточно активов.



Значит, Вы удовлетворяете новое руководство?

Тяжело пока ответить уверенно. Если мы говорим о том, что Моратти и Берлускони – ярые фанатики, но постепенно у них нет возможностей вкладывать финансы в проект, то свежее влияние, тем более свежая кровь должна нормализировать структуру клуба, со временем.

М. Я хотел бы подчеркнуть, мой кузен, правильно отметил – “президент футбольного клуба должен быть фанатом”. Что касается покупки команды то, в отличие от англичан, итальянская школа превосходит представителей туманного альбиона. Мы делаем упор на молодёжь, обрати внимание на нынешний «Милан», далеко ходить не будем, или «Сассуоло», сегодняшняя «Аталанта» стала набирать обороты. Называть имён молодых игроков, думаю не станем [смеётся], чтобы не обидеть болельщиков АПЛ, но любой клуб оттуда покупает футболистов за бешеные деньги на те же самые позиции, где в Италии доверяют молодёжке. В последнее время англичане сдали в вопросе воспитания поколения. «Вест Хэм», являвшийся хорошей селекцией, многими забыт. С одной стороны, неприятно было смотреть, когда заинтересованных инвесторов по Апеннинскому полуострову не было. Если тифози «Интера» переживают и не могут разобраться, что ожидать от компании «Suning», то у “россонери” ситуация чуть хуже. Главное, в любом случае, чтобы нас не кинули, понимаешь. [смеются оба]. Судьба «Пармы» на лицо, все знают, где она сейчас. Тохир? С ним не понятны его действия. Вроде купил активы “нерадзурри”, давал обещания, спустя время он перепродаёт клуб. И здесь истина вырисовывается, Эрик Тохир – не фанат «Интера».



Впрочем, есть минусы и плюсы. Каким бы не были Берлускони и Моратти, признающиеся в любви своим цветам команды, они изжили себя, поэтому необходимо привнести что-то новое.

2. Что повлияло болеть за Ваш любимый клуб? Может быть кто – то Вас подтолкнул к этому?



И.Знаешь, всё началось с 1998 года, когда на зелёном поле просто феерил и приманивал к себе Роналдо, назовём его “оригинал” [смеётся]. В те дни чемпионата мира во Франции я не разбирался детально в футболе, смотрел, как нейтральный зритель. У меня был одноклассник, который отлично знал спорт №1, и я у него стал расспрашивать: «Слушай, Алмаз, кто это за футболист? Где он играет, расскажи о нём». Позже, узнав всю информацию, в голове у меня потихоньку начал строиться фундамент о бразильце и его, в тот момент, действующем клубе «Интер». Постепенно, стал интересоваться, вливаться в футбол и уже начал не пропускать игры своей команды. Да, матчи некоторые “нерадзурри” ставят в ночь на воскресенье понедельника, впрочем, ради клуба работа отходит на второй план.

…Как ни крути, Роналдо улетел в Мадрид, а «Интер» остался в моих сердцах. [смеётся]

М. Отец любил футбол. Отдавал своё предпочтение за Бразилию. В 94ом, когда проходил кубок мира, я ещё маленький, естественно, не понимающий в игре ничего – просто смотрел по телевизору “кто там и что там?” Матчи шли, как и следовало по расписанию, и вот когда футболисты в синих футболках, где дирижировал “хвостик” появились — тут уже я стал наслаждаться этим волшебником и его командой. Врать не буду, встречи я смотрел не с группового этапа: судьба свела с 1/8, и постепенно я дошёл до финала. Конечно, заключительный матч стал трагичным. А потом, настали клубные пристрастия. Возможно, я бы не стал фанатом “россонери”, если бы не трансфер Роберто Баджо в «Милан». Но, самое главное, ко мне никто не может придраться, тогдашняя команда была на спаде, в составе играли Баджо, Веа и мн.др. Старт последующем был кошмарным по итоговой таблице, вскоре Баджо ушёл из «Милана». Но клуб я полюбил на всю жизнь – его арену и преданных тифози. Процитирую золотую мысль одного из уважаемых болельщиков “россонери”: « «Милан» — это не герб и не какой-нибудь президент или олицетворение футболиста. «Милан» — горячее преданность болельщиков». Я только-только отдающее своё сердце “россонери”, увидев их гигантский перфоманс, влюбился в «Милан»; даже уход Баджо не сыграл болезненный эпизод в этом плане.



Безусловно, мне повезло, когда я увидел легендарный финал в Афинах 94ого. Хотя я был маленьким, но «Милан» и мной увиденный второй тайм, наверное, тогда стал отголоском после чемпионата мира, за кого я буду болеть.

После, прилетал Бирхофф, хорошо показал себя; конечно, золотой мяч Джорджа Веа – это отдельный заголовок. Со временем, Шевченко потихоньку начал оклиматизироваться в рядах «Милана» и болельщиков. И дальше было больше…

3. Любой, кто скажет, что он за «Барселону», каждому понятно их стиль “тики-така”. В Вашем понимании «Интер» — это чистое катеначчо тех 60ых годов или же структура игры лежит в атаке?



Для меня «Интер» является в том превосходном уровне, когда Жозе Моуриньо руководил “нерадзурри”. Это сбалансированность между тремя линиями на поле. Сейчас мы ждём, когда придёт тренер на долгое время и приведёт состав на такой же уровень. Конечно же, Диего Симеоне подошёл бы на такую роль.

2010 год. Триплетта. Что запомнилось?



Эмоции взорвались, когда мы прошли «Барселону». В Мадрид на “баварцев” мы шли с таким настроем, что мюнхенцы уже психологически были подавлены. Диего Милито? Каким он пришёл и что он показал – здесь, в большей степени, работа тренера. Однако, и чемпионат, и кубок, и тем более ЛЧ – было под его властью. Жаль, что развить свой успех ему не удалось, но тот «Интер» [все без исключения останутся на всю жизнь в сердцах болельщиков].

4. Приходилось – ли быть свидетелем перемен в самом составе любимой команды? Ощущалось опасение за свой любимый клуб?



И. Это крайне болезненный этап. Дзанетти играет, кажется против Лихтштайнера, если не ошибаюсь – а комментатор кричит по телевизору: «… тебя старик возит, что ты делаешь?!» [смеётся].

И представь, каково нам, чтобы такой футболист играл вечно; конечно, смена поколений процесс не обратим, и когда приходит молодёжь, а по арене возгласом проходит с каждой трибуны твоё имя – здесь, титаническое давление. В конце концов, футболист юный преодолевает барьер. Икарди, вот, лучший бомбардир Серии А 14/15. Капитанская повязка? Сейчас очень тяжело выбрать лидера после Дзанетти. Был Раноккья, но все поняли, что он из себя представляет. Думаю, что аргентинцу надо предоставить шанс.

М. Тревоги по смену поколений, как то не прослеживалось. К примеру, когда на тренерском мостике находился “папа Карло” – проблем хватало и с ним. В общем – то, что он сделал, помнят до сих пор [его трофеи с “россонери”]. Да, Анчелотти хотел привнести в состав новое после 2007 года, но у него не вышло, а игроки из старой гвардии были в строю. Приходил голландец Хунтеллар, например, но костяк оставался. И, по сути, детище Карло Анчелотти терялось в минуты, но Гаттузо, Зеедорф, Амброзини и пр. др не вызывали никаких сомнений.

Сейчас же, после “кальчополи” революция сыграла свою роль под этот вердикт попали, скажем грубо, все команды Италии, так что наблюдать за сменой состава, как оно есть, в общем – то приходится следить на данную минуту.

Отступление от вопросов. Герои стали раскрываться



И. Понимаешь, Derby della Madonnina отличается тем, что битва на поле проходит не только между командами, но и между болельщиками. Мне посчастливилось побыть в этом “театре”. Когда ты там, со своими фанатами поёшь то, что они, не вдаваясь в перевод; чувствуешь поддержку, переносящую на поле игрокам “нерадзурри”, мурашки по коже, адреналин зашкаливает до предела – это сказка!.. В какой-то момент, нам не важно было, что происходит на футбольном газоне, у болельщиков появилась своя игра. Как то я не встречал позже, чтобы различные дерби олицетворяли хотя бы в малой доли наше Дерби ди Милано.

М. Я лишь напомню, всем известный факт, что две команды из города Милан – единственные, которые поднимали над собой кубок Лиги Чемпионов. А его главную арену «Сан-Сиро» я сравниваю, без всяких преувеличений с 8ым чудо света.

И. Абсолютно согласен с моим кузеном, только лишь поправлю, что стадион именуется «им. Джузеппе Меацца». [интервью уже входит в стадию юморного задора друг на друга]

М. Моё мнение по теме собственной арены для «Милана» и “нерадзурри”. У «Юве», допустим, свой стадион, но у неё нет той атмосферы и ауры, которая просто летает по полю даже, когда нет матчей на «Сан-Сиро им. Джузеппе Меацца».

И. Но, в реалии сегодняшнего дня, понимаем, что необходима своя арена. Тохир, занимая пост «Интера» разговаривал с Барборой Берлускони о ситуации вокруг главного стадиона Милана. Если бы было в городе, представим, две арены, наверное бы, это стало плюсом для всех. Спустя время выявляются новые детали в СМИ по вопросу стадиона и, пока, всё уходит в сторону. Моё мнение, собственная арена нужна.

продолжение по ссылке.
Читать дальше →